fix: Electron 5 support.

fix-builder
Hristo Terezov 3 years ago
parent 930797f7d6
commit 061fbf9f88
  1. 6
      main.js
  2. 5565
      package-lock.json
  3. 6
      package.json

@ -18,6 +18,9 @@ const {
const path = require('path');
const URL = require('url');
// We need this because of https://github.com/electron/electron/issues/18214
app.commandLine.appendSwitch('disable-site-isolation-trials');
autoUpdater.logger = require('electron-log');
autoUpdater.logger.transports.file.level = 'info';
@ -134,7 +137,8 @@ function createJitsiMeetWindow() {
minHeight: 600,
show: false,
webPreferences: {
nativeWindowOpen: true
nativeWindowOpen: true,
nodeIntegration: true
}
};

5565
package-lock.json generated

File diff suppressed because it is too large Load Diff

@ -91,12 +91,12 @@
"electron-debug": "2.0.0",
"electron-is-dev": "1.0.1",
"electron-log": "2.2.17",
"electron-reload": "1.4.0",
"electron-reload": "1.5.0",
"electron-store": "2.0.0",
"electron-updater": "4.0.6",
"electron-window-state": "5.0.3",
"history": "4.7.2",
"jitsi-meet-electron-utils": "github:jitsi/jitsi-meet-electron-utils#v0.6.7",
"jitsi-meet-electron-utils": "github:jitsi/jitsi-meet-electron-utils#v0.6.9",
"js-utils": "github:jitsi/js-utils#0c53500a5120be2aa3fc590f0f932a0d4771920f",
"moment": "2.23.0",
"mousetrap": "1.6.2",
@ -125,7 +125,7 @@
"concurrently": "4.1.0",
"css-loader": "2.0.1",
"devtron": "1.4.0",
"electron": "4.1.5",
"electron": "5.0.11",
"electron-builder": "20.38.3",
"electron-react-devtools": "0.5.3",
"eslint": "5.10.0",

Loading…
Cancel
Save