Update dependencies

fix-builder
Saúl Ibarra Corretgé 4 years ago committed by Hristo Terezov
parent c95a9a61c3
commit 6884b08e57
  1. 4469
      package-lock.json
  2. 76
      package.json
  3. 11
      webpack.renderer.js

4469
package-lock.json generated

File diff suppressed because it is too large Load Diff

@ -75,66 +75,70 @@
"readmeFilename": "README.md",
"license": "Apache-2.0",
"dependencies": {
"@atlaskit/avatar": "14.0.6",
"@atlaskit/button": "9.0.5",
"@atlaskit/css-reset": "3.0.1",
"@atlaskit/droplist": "7.0.5",
"@atlaskit/field-text": "7.0.4",
"@atlaskit/icon": "13.2.4",
"@atlaskit/navigation": "33.1.4",
"@atlaskit/onboarding": "5.1.4",
"@atlaskit/page": "8.0.3",
"@atlaskit/spinner": "9.0.5",
"@atlaskit/theme": "5.1.3",
"@atlaskit/toggle": "5.0.5",
"@atlaskit/avatar": "14.0.10",
"@atlaskit/button": "9.0.12",
"@atlaskit/css-reset": "3.0.2",
"@atlaskit/droplist": "7.0.9",
"@atlaskit/field-text": "7.0.11",
"@atlaskit/icon": "13.9.0",
"@atlaskit/navigation": "33.1.10",
"@atlaskit/onboarding": "6.0.1",
"@atlaskit/page": "8.0.5",
"@atlaskit/spinner": "9.0.9",
"@atlaskit/theme": "6.0.4",
"@atlaskit/toggle": "5.0.8",
"electron-debug": "2.0.0",
"electron-is-dev": "0.3.0",
"electron-log": "2.2.16",
"electron-is-dev": "1.0.1",
"electron-log": "2.2.17",
"electron-reload": "1.2.5",
"electron-updater": "3.1.1",
"electron-window-state": "4.1.1",
"electron-updater": "3.1.2",
"electron-window-state": "5.0.1",
"history": "4.7.2",
"jitsi-meet-electron-utils": "github:jitsi/jitsi-meet-electron-utils#1972c3bf0884ace68eb496894dabae593d6dbf49",
"js-utils": "github:jitsi/js-utils#0c53500a5120be2aa3fc590f0f932a0d4771920f",
"moment": "2.22.2",
"mousetrap": "1.6.2",
"react": "16.4.2",
"react-dom": "16.4.2",
"react": "16.5.2",
"react-dom": "16.5.2",
"react-redux": "5.0.7",
"react-router-redux": "5.0.0-alpha.9",
"redux": "4.0.0",
"redux-logger": "3.0.6",
"redux-persist": "5.10.0",
"redux-persist-electron-storage": "1.1.2",
"styled-components": "3.4.2"
"source-map-support": "0.5.9",
"styled-components": "3.4.9"
},
"devDependencies": {
"babel-core": "6.26.3",
"babel-eslint": "8.2.6",
"babel-loader": "7.1.5",
"@babel/core": "7.1.2",
"@babel/plugin-proposal-class-properties": "7.1.0",
"@babel/plugin-proposal-export-namespace-from": "7.0.0",
"@babel/plugin-transform-flow-strip-types": "7.0.0",
"@babel/preset-env": "7.1.0",
"@babel/preset-flow": "7.0.0",
"@babel/preset-react": "7.0.0",
"babel-eslint": "10.0.1",
"babel-loader": "8.0.4",
"babel-plugin-inline-react-svg": "0.5.4",
"babel-preset-env": "1.7.0",
"babel-preset-react": "6.24.1",
"babel-preset-stage-1": "6.24.1",
"concurrently": "3.6.1",
"concurrently": "4.0.1",
"css-loader": "1.0.0",
"devtron": "1.4.0",
"electron": "3.0.2",
"electron-builder": "20.28.1",
"electron-builder": "20.28.4",
"electron-react-devtools": "0.5.3",
"eslint": "5.3.0",
"eslint": "5.6.1",
"eslint-config-jitsi": "github:jitsi/eslint-config-jitsi#v0.1.0",
"eslint-plugin-flowtype": "2.50.0",
"eslint-plugin-flowtype": "2.50.3",
"eslint-plugin-import": "2.14.0",
"eslint-plugin-jsdoc": "3.7.1",
"eslint-plugin-react": "7.11.0",
"file-loader": "1.1.11",
"flow-bin": "0.78.0",
"eslint-plugin-jsdoc": "3.8.0",
"eslint-plugin-react": "7.11.1",
"file-loader": "2.0.0",
"flow-bin": "0.81.0",
"html-webpack-plugin": "3.2.0",
"precommit-hook": "3.0.0",
"style-loader": "0.22.1",
"style-loader": "0.23.0",
"svg-inline-loader": "0.8.0",
"webpack": "4.16.5",
"webpack-cli": "3.1.0"
"webpack": "4.20.2",
"webpack-cli": "3.1.2"
}
}

@ -27,7 +27,7 @@ module.exports = {
babelrc: false,
presets: [
[
require.resolve('babel-preset-env'),
require.resolve('@babel/preset-env'),
{
modules: false,
targets: {
@ -35,10 +35,15 @@ module.exports = {
}
}
],
require.resolve('babel-preset-react'),
require.resolve('babel-preset-stage-1')
require.resolve('@babel/preset-flow'),
require.resolve('@babel/preset-react')
],
plugins: [
/* eslint-disable max-len */
require.resolve('@babel/plugin-transform-flow-strip-types'),
require.resolve('@babel/plugin-proposal-class-properties'),
require.resolve('@babel/plugin-proposal-export-namespace-from'),
/* eslint-enable max-len */
require.resolve('babel-plugin-inline-react-svg')
]
},

Loading…
Cancel
Save