Browse Source

Update dependencies

fix-builder
Saúl Ibarra Corretgé 4 years ago committed by Hristo Terezov
parent
commit
dc22d9f5a6
  1. 3
      .flowconfig
  2. 2
      app/features/recent-list/reducer.js
  3. 4746
      package-lock.json
  4. 75
      package.json

3
.flowconfig

@ -1,5 +1,6 @@
[ignore]
<PROJECT_ROOT>/node_modules/@atlaskit/.*/*.js.flow
<PROJECT_ROOT>/node_modules/redux-persist/.*/*.js.flow
<PROJECT_ROOT>/build/.*
<PROJECT_ROOT>/dist/.*
@ -11,4 +12,4 @@
[options]
[strict]
[strict]

2
app/features/recent-list/reducer.js

@ -55,7 +55,7 @@ function _insertConference(
newConference.startTime = Date.now();
// Remove same conference.
const newRecentList = recentList.filter(
const newRecentList: Array<RecentListItem> = recentList.filter(
(conference: RecentListItem) => conference.room !== newConference.room
|| conference.serverURL !== newConference.serverURL);

4746
package-lock.json generated

File diff suppressed because it is too large Load Diff

75
package.json

@ -75,70 +75,71 @@
"readmeFilename": "README.md",
"license": "Apache-2.0",
"dependencies": {
"@atlaskit/avatar": "14.1.1",
"@atlaskit/button": "9.0.13",
"@atlaskit/css-reset": "3.0.2",
"@atlaskit/droplist": "7.0.10",
"@atlaskit/field-text": "7.0.11",
"@atlaskit/icon": "14.0.1",
"@atlaskit/navigation": "33.2.0",
"@atlaskit/onboarding": "6.0.2",
"@atlaskit/page": "8.0.7",
"@atlaskit/spinner": "9.0.9",
"@atlaskit/theme": "6.1.0",
"@atlaskit/toggle": "5.0.9",
"@atlaskit/avatar": "14.1.7",
"@atlaskit/button": "10.1.1",
"@atlaskit/css-reset": "3.0.5",
"@atlaskit/droplist": "7.0.17",
"@atlaskit/field-text": "7.0.19",
"@atlaskit/icon": "15.0.3",
"@atlaskit/navigation": "33.3.8",
"@atlaskit/onboarding": "6.1.14",
"@atlaskit/page": "8.0.12",
"@atlaskit/spinner": "9.0.13",
"@atlaskit/theme": "7.0.1",
"@atlaskit/toggle": "5.0.14",
"electron-debug": "2.0.0",
"electron-is-dev": "1.0.1",
"electron-log": "2.2.17",
"electron-reload": "1.2.5",
"electron-updater": "3.1.2",
"electron-window-state": "5.0.1",
"electron-reload": "1.4.0",
"electron-store": "2.0.0",
"electron-updater": "4.0.6",
"electron-window-state": "5.0.3",
"history": "4.7.2",
"jitsi-meet-electron-utils": "github:jitsi/jitsi-meet-electron-utils#1972c3bf0884ace68eb496894dabae593d6dbf49",
"js-utils": "github:jitsi/js-utils#0c53500a5120be2aa3fc590f0f932a0d4771920f",
"moment": "2.22.2",
"moment": "2.23.0",
"mousetrap": "1.6.2",
"react": "16.5.2",
"react-dom": "16.5.2",
"react-redux": "5.0.7",
"react": "16.6.3",
"react-dom": "16.6.3",
"react-redux": "5.1.1",
"react-router-redux": "5.0.0-alpha.9",
"redux": "4.0.0",
"redux": "4.0.1",
"redux-logger": "3.0.6",
"redux-persist": "5.10.0",
"redux-persist-electron-storage": "1.1.2",
"redux-persist-electron-storage": "2.0.0",
"source-map-support": "0.5.9",
"styled-components": "3.4.10"
"styled-components": "3.4.0"
},
"devDependencies": {
"@babel/core": "7.1.2",
"@babel/plugin-proposal-class-properties": "7.1.0",
"@babel/plugin-proposal-export-namespace-from": "7.0.0",
"@babel/plugin-transform-flow-strip-types": "7.0.0",
"@babel/preset-env": "7.1.0",
"@babel/core": "7.2.2",
"@babel/plugin-proposal-class-properties": "7.2.1",
"@babel/plugin-proposal-export-namespace-from": "7.2.0",
"@babel/plugin-transform-flow-strip-types": "7.2.0",
"@babel/preset-env": "7.2.0",
"@babel/preset-flow": "7.0.0",
"@babel/preset-react": "7.0.0",
"babel-eslint": "10.0.1",
"babel-loader": "8.0.4",
"babel-plugin-inline-react-svg": "1.0.0",
"concurrently": "4.0.1",
"css-loader": "1.0.0",
"babel-plugin-inline-react-svg": "1.0.1",
"concurrently": "4.1.0",
"css-loader": "2.0.1",
"devtron": "1.4.0",
"electron": "3.0.3",
"electron-builder": "20.28.4",
"electron": "3.0.13",
"electron-builder": "20.38.3",
"electron-react-devtools": "0.5.3",
"eslint": "5.6.1",
"eslint": "5.10.0",
"eslint-config-jitsi": "github:jitsi/eslint-config-jitsi#v0.1.0",
"eslint-plugin-flowtype": "2.50.3",
"eslint-plugin-flowtype": "3.2.0",
"eslint-plugin-import": "2.14.0",
"eslint-plugin-jsdoc": "3.8.0",
"eslint-plugin-jsdoc": "3.14.0",
"eslint-plugin-react": "7.11.1",
"file-loader": "2.0.0",
"flow-bin": "0.81.0",
"flow-bin": "0.89.0",
"html-webpack-plugin": "3.2.0",
"precommit-hook": "3.0.0",
"style-loader": "0.23.1",
"svg-inline-loader": "0.8.0",
"webpack": "4.20.2",
"webpack": "4.27.1",
"webpack-cli": "3.1.2"
}
}

Loading…
Cancel
Save