Jitsi Meet desktop application powered by
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 

146 lines
4.5 KiB

{
"name": "netzbegruenung-konferenz",
"version": "2.0.0",
"description": "Electron application for Netzbegruenung Konferenz (Jitsi Meet)",
"main": "./build/main.js",
"productName": "Netzbegruenung Konferenz",
"scripts": {
"start": "webpack --config ./webpack.main.js --mode development && concurrently \"npm:watch\" \"electron ./build/main.js\"",
"clean": "rm -rf node_modules build dist",
"lint": "eslint . && flow",
"build": "webpack --config ./webpack.main.js --mode production && webpack --config ./webpack.renderer.js --mode production",
"pack": "npm run build && electron-builder --dir",
"dist": "npm run build && electron-builder",
"postinstall": "electron-builder install-app-deps",
"validate": "npm ls",
"watch": "webpack --config ./webpack.renderer.js --mode development --watch --watch-poll"
},
"build": {
"appId": "de.netzbegreunung.konferenz",
"productName": "Netzbegruenung Konferenz",
"generateUpdatesFilesForAllChannels": true,
"files": [
"**/*",
"resources",
"!app",
"!main.js"
],
"mac": {
"artifactName": "netzbegruenung-konferenz.${ext}",
"category": "public.app-category.video",
"darkModeSupport": true
},
"linux": {
"artifactName": "netzbegruenung-konferenz-${arch}.${ext}",
"category": "VideoConference;AudioVideo;Audio;Video;Network",
"description": "Netzbegruenung Konferenz Desktop App",
"executableName": "netzbegruenung-konferenz",
"target": [
{
"arch": "x64",
"target": "AppImage"
}
]
},
"win": {
"artifactName": "netzbegruenung-konferenz.${ext}",
"target": [
{
"arch": [
"ia32",
"x64"
],
"target": "nsis"
}
]
},
"directories": {
"buildResources": "resources"
}
},
"pre-commit": [
"lint"
],
"repository": {
"type": "git",
"url": "git://github.com/netzbegruenung/jitsi-meet-electron"
},
"keywords": [
"jingle",
"webrtc",
"xmpp",
"electron",
"jitsi-meet"
],
"author": "Netzbegruenung <support@netzbegruenung.de>",
"readmeFilename": "README.md",
"license": "Apache-2.0",
"dependencies": {
"@atlaskit/avatar": "14.1.7",
"@atlaskit/button": "10.1.1",
"@atlaskit/css-reset": "3.0.5",
"@atlaskit/droplist": "7.0.17",
"@atlaskit/field-text": "7.0.19",
"@atlaskit/icon": "15.0.3",
"@atlaskit/navigation": "33.3.8",
"@atlaskit/onboarding": "6.1.14",
"@atlaskit/page": "8.0.12",
"@atlaskit/spinner": "9.0.13",
"@atlaskit/theme": "7.0.1",
"@atlaskit/toggle": "5.0.14",
"electron-debug": "3.0.1",
"electron-is-dev": "1.2.0",
"electron-log": "4.1.1",
"electron-reload": "1.5.0",
"electron-store": "5.1.1",
"electron-updater": "4.2.5",
"electron-window-state": "5.0.3",
"history": "4.10.1",
"jitsi-meet-electron-utils": "github:jitsi/jitsi-meet-electron-utils#v2.0.3",
"js-utils": "github:jitsi/js-utils#0c53500a5120be2aa3fc590f0f932a0d4771920f",
"moment": "2.23.0",
"mousetrap": "1.6.2",
"react": "16.6.3",
"react-dom": "16.6.3",
"react-redux": "5.1.1",
"react-router-redux": "5.0.0-alpha.9",
"redux": "4.0.1",
"redux-logger": "3.0.6",
"redux-persist": "5.10.0",
"redux-persist-electron-storage": "2.0.0",
"source-map-support": "0.5.16",
"styled-components": "3.4.0"
},
"devDependencies": {
"@babel/core": "7.9.0",
"@babel/plugin-proposal-class-properties": "7.8.3",
"@babel/plugin-proposal-export-namespace-from": "7.8.3",
"@babel/plugin-transform-flow-strip-types": "7.9.0",
"@babel/preset-env": "7.9.0",
"@babel/preset-flow": "7.9.0",
"@babel/preset-react": "7.9.4",
"babel-eslint": "10.0.3",
"babel-loader": "8.1.0",
"babel-plugin-inline-react-svg": "1.1.1",
"concurrently": "5.1.0",
"css-loader": "3.5.0",
"devtron": "1.4.0",
"electron": "8.2.1",
"electron-builder": "22.3.6",
"electron-react-devtools": "0.5.3",
"eslint": "6.5.1",
"eslint-config-jitsi": "github:jitsi/eslint-config-jitsi#1.0.2",
"eslint-plugin-flowtype": "4.7.0",
"eslint-plugin-import": "2.20.2",
"eslint-plugin-jsdoc": "22.1.0",
"eslint-plugin-react": "7.19.0",
"file-loader": "6.0.0",
"flow-bin": "0.109.0",
"html-webpack-plugin": "4.0.4",
"precommit-hook": "3.0.0",
"style-loader": "1.1.3",
"svg-inline-loader": "0.8.2",
"webpack": "4.42.1",
"webpack-cli": "3.3.11"
}
}